What are the minimum requirements to run IRIS Clarity?

IRIS Clarity works on:

  • Windows 10, Windows 11, and above
  • macOS 12 (Monterey) and above
  • All the common VoIP platforms that run on your laptop (e.g. Five9, 8x8, RingCentral, Vonage, Avaya, Genesis, etc.), including softphones

IRIS Clarity does not work on:

  • Intel Pentium or Intel Celeron processors, even those produced after 2011, as they do not support AVX instructions
  • Standalone phones